[alsa-devel] hda-intel on macbook5, 1 (was: lockdep warning on 2.6.29-rc1 with pulseaudio)

Johannes Berg johannes at sipsolutions.net
Wed Jan 14 11:19:08 CET 2009

On Wed, 2009-01-14 at 07:47 +0100, Takashi Iwai wrote:

> > I'm sorry I phrased that wrongly, I'm not aware of any working kernel
> > version.
> Ah OK, then it's no regression, at least :)

No :)

> > I've tried googling for this macbook 5,1 (13.3") issue, and have found
> > various information, some people claim it should work, but it doesn't
> > seem to for me with the same software versions...
> Did you try some model options?  For example, model=macpro, model=mbp3,
> or model=imac24.

Yes, I'm not sure which ones I tried, so I just went back and tried
these, no help. The optical output lights up when I enable it, but I
have no way to check if anything is modulated onto it. Your initial
comment seems to make sense, some GPIO line that controls the PA is
maybe not enabled? Unfortunately Apple hasn't published their driver as
open source, afaict.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20090114/47e469ed/attachment.sig 

More information about the Alsa-devel mailing list