[alsa-devel] DELL SP2309W Monitor with Integrated microphone

Phil Gorbett pgorbett at usc.edu.au
Sat Apr 11 02:50:42 CEST 2009

Any luck anyone with this one yet?  I too have the same issue as that
posted previously (last month), and get the same results with the
indicative testing.  I have tried several fixes via googling - module
loading and sound "card" indexing via alsa.base modprobe file and LOTS
of others.  Still no luck.  I am running FC10 with pulse, but think it's
probably a snd-usb-audio problem as the driver appears to be correctly
loading and the webcam is clearly indicated in the sound prefs app and
gconf/gstreamer.  I have run thru the usb audio device classes, and all
of the reported class values reported via lsusb -v seem to correctly
correspond to possible values from the audio class parameters.  I'm now
stumped.  I do get the following errors in the gnome sound recorder:
"Could not negotiate format" followed by "Could not get/set settings
from/on resource.". This jives with the error from the sound preference
panel: "gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink
profile=chat: Could not get/set settings from/on resource." which does
not reveal anything specific enough to track down the problem from
searching the net.  All other sound devices and services are performing
correctly via pulseaudio.  I have at one time removed p/a, but this did
not correct the problem.  I am running the webcam mic as device 0, but
changing that to any other device number fails to solve the problem.
Alsamixer shows the card "Monitor Webcam" mic, the chip "USB mixer", the
recording levels at 74, the capture enabled, and the AGC and loudness
parameters enabled, and although I have tried various combinations of
these, none have worked.

I am running version 1.0.19 of the alsa drivers, and compiled these
directly with all everything enabled as well as using the rpm builds.
Alsainfo has been uploaded to:


The video portion of the camera functions entirely correctly via uvc and
v4l, but the audio listing from the video test app gucveiw does not list
the webcam mic at all under the audio device list.  The uvc dev group
sent me here, naturally.


More information about the Alsa-devel mailing list