[alsa-devel] hda-intel - Add digout to ALC880 F1734 model

Takashi Iwai tiwai at suse.de
Sun Nov 2 12:23:52 CET 2008

At Sat, 1 Nov 2008 13:43:25 +0100,
Michael Gruber wrote:
> Backstory:
> The patch "ALSA: hda - Add infrastructure for dynamic stream allocation"
> http://git.alsa-project.org/?p=alsa-kmirror.git;a=commit;h=ae32c9fe811fed22715342494c08a11fabc87762
> broke the detection of my card. With this patch applied the dmesg output is:
> [ 3761.464838] ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level,
> low) -> IRQ 16
> [ 3761.464863] PCI: Setting latency timer of device 0000:00:1b.0 to 64
> [ 3761.499927] ACPI: PCI interrupt for device 0000:00:1b.0 disabled
> [ 3761.499945] HDA Intel: probe of 0000:00:1b.0 failed with error -22

Could you check whether you get any other error messages with

> When I loaded the module with model=... then it would work only for some
> models, but not for others. I found out that the ones which worked were the
> ones with a digout. I added the digout to the F1734 model and now it is
> working again.
> I can't test if the digout is really working because I lack the hardware, but
> when I turn on the IEC958 control in the mixer then red light is emitted from
> my headphone port.
> I will attach a patch that adds digout to this model because this seems the
> right thing to do, but I don't know whether there is something wrong with the
> aforementioned patch that caused my problem in the first place.

Yeah, it shouldn't break the existing thing, at least.



More information about the Alsa-devel mailing list