[alsa-devel] [Alsa-user] ICH8 HDA not detected after upgrade from Ubuntu 7.10 to 8.04

stan ghjeold_i_mwee at cox.net
Sun May 25 23:50:35 CEST 2008

Janto Schraiber wrote:
> I got the ASUS P5B mainboard with an Intel HDA compatible Soundchip 
> (Analog Devices... AD 1988B afaik but I'm not realy sure about that). 
> Under Ubunt 7.10 it works out of the box but I just recently updated 
> to the new Ubuntu 8.04 where the card is no longer detected.
> There are some post on the web about the problem, but most deal with 
> issues, after you get details per 'head -n 1 
> /proc/asound/card0/codec*' or the like, but sine the card is not 
> detected at all, i get no info from commands like that... see:
> $ cat /proc/asound/cards
> --- no soundcards ---
> I installed the latest drivers from source, but it doesn't help. I 
> also tried to update the kernel, etc. from the 'hardy-proposed' 
> repository, still no luck.
> Here's the output from the 'alsa-info.sh' script:
> http://pastebin.ca/1028944
> And here's my dmesg:
> http://pastebin.ca/1028967
> What should I do to get my card working again?
 From your dmesg here's the problem.
HDA Intel: probe of 0000:00:1b.0 failed with error -16

I'm not a developer so I don't know what that means, just that it is not 

I think this is an issue for some hda-intel cards in kernel version 
2.6.25.  In the cases I have seen the card was working on the 24 version 
kernel, but when they moved to 25 it stopped working.  That is, it's a 
regression.  I don't think there is anything you can do until the 
problem is fixed there.  Using the earlier kernel is probably not 
possible with the rest of the system.  I don't know this, but suspect 
it.  You could try compiling an earlier kernel on your system. 

I'll cross post this to the alsa-devel mailing list so the developers 
become aware of the problem.

More information about the Alsa-devel mailing list