[alsa-devel] Problem with intel-hda integrated audio

Matteo Sasso matteo.sasso at gmail.com
Thu May 22 21:38:35 CEST 2008

Hello, I'm having a problem with a soundcard under ubuntu. I tried nearly 
every workaround I could find on the Internet but I have not been successful 
so far.

The computer in question is a Toshiba Satellite Pro U200 series. The soundcard 
seems to be correctly identified by ALSA but it seems muted, nothing I tried 
seems to work. I followed the instructions given at
I determined that my card uses a AD1981 codec, so I added the following 
to /etc/modprobe.d/alsa-base:

options snd-hda-intel model=toshiba

I tried many other combinations (3stack, basic, laptop), with and 
without "position_fix=1". I also tried using underscores instead of hypens 
("snd_hda_intel"). I run update-initramfs -u after every try.

lspci -vn has to say the following:
00:1b.0 0403: 8086:27d8 (rev 02)
        Sybsystem: 1179:0001
        Flags: bus master, fast devsel, latency 0, IRQ 23
        Memory at 50080000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ 
Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0

I'll keep tabs on this mailing list, so feel free to ask for more info.
Any help is appreciated.

More information about the Alsa-devel mailing list