[alsa-devel] No sound on MacBook 3.1

stan ghjeold_i_mwee at cox.net
Wed Jun 25 19:05:27 CEST 2008

Marco Vermeulen wrote:
> Hi there,
> I hope that someone can help me, as I've tried everything conceivable to
> get sound working on my Macbook 3.1. I've visited many a forum, and
> eventually came across this list. My last hope :)
> I purchased a Macbook 3.1 earlier this year. On installing Linux, I
> haven't been able to get any sound going. I've tried several
> distributions: Ubuntu Hardy, Fedora 8/9, and now openSuse. I came across
> a script that uploads local relevant information to a paste bin, so
> here's a link:
> http://pastebin.ca/1055610
> Please help, I'm desperate to get this going on my machine!
> Thanks & Regards,
> Marco.
It looks like you should have sound.  Alsa is recognizing your card and 
loading the driver.

You could upgrade to alsa 1.0.17.RC2 to see if that helps.
You could try sending parameters to the driver load (3-stack, 6-stack, 
etc.) to see if that helps.

Also try aplay -D plughw:0,0  some.wav to see if there is any sound.

Are you running any sound servers?  They can interfere if the rest of 
the system isn't compatible with them.

Maybe someone else here knows exactly what is wrong.

More information about the Alsa-devel mailing list