[alsa-devel] aplay works but not real player

Harsha priya gupta harshapriya at gmail.com
Fri Jun 6 09:49:40 CEST 2008

I did not try xmms but amarok and kaffine play the files in suse flavour.
But i am still not able to get the real player working. Can anyone help me
what else configuration i have to set for real player to work?

On Fri, Jun 6, 2008 at 12:02 AM, stan <ghjeold_i_mwee at cox.net> wrote:

> Harsha priya gupta wrote:
>> I am using .copy function in my driver.
>> aplay playes any .wav file given. When i open real player and try playing
>> it
>> says device is busy.
>> I tried the earlier advice to write the following into ~./asoundrc but
>> does
>> not help
>> pcm.!default{
>> type hw
>> card 0
>> }
>> any clue that can help me ?
> Have you got realaudio configured to use alsa or oss?  If oss, do you have
> package aoss installed,
> the alsa oss emulation layer?  Whatever device it wants to use is
> in use by something else.  A sound server can cause this problem as well.
> Try with something like xmms or audacity also.
> The fact that aplay can play means this is a configuration issue.


More information about the Alsa-devel mailing list