[alsa-devel] Repost: snd-hda-intel[ALC883] scratching and stuttering sound on MCP78S board

Hans-Frieder Vogt hfvogt at gmx.net
Sun Jul 20 19:10:49 CEST 2008

Hi List,

This is just an updated repost of my request from a month ago. So far I have not achieved to solve the problem myselves, therefore I would very much appreciate ANY hint as to what (and even more important: where) to look for.

Here is a summary of my problem and some related info:

I am experiencing severely scratching and stuttering sound on my nVidia MCP78S (GeForce 8200) based Asus M3N78-EMH HDMI mainboard, which has an ALC883 on board, running with an Athlon X2 4850e dual-core CPU.
It sounds, as if the sound buffers are not filled in time and are therefore repeated many times (2 to 4 times) per second. The problem seems to be kernel / alsa-driver related, because I experience the problem also when running runlevel 1 with only a minimum of active processes (e.g. without graphics).

Strange enough, the sound is OK when I do a larger compilation in parallel (kernel make with make -j 2), but the sound is not OK when I run burnK7 (two instances to sufficiently load both CPU cores) => What is different in CPU loading or scheduling between these two load cases?
Also, the sound is OK when I copy large files in parallel.

Could it be related, that lspci gives me for all devices a latency of 0, even though the kernel message tell me that it was set to 64? I cannot change the PCI latency to another value via setpci.

I am using Message Signal Interrupts for HD Audio, although switching it off also makes no audible difference. My Interrupt distribution is:
           CPU0       CPU1
  0:         39          1   IO-APIC-edge      timer
  1:         61      27962   IO-APIC-edge      i8042
  6:          0          5   IO-APIC-edge      floppy
  7:          1          0   IO-APIC-edge
  8:          0          1   IO-APIC-edge      rtc0
  9:          0          0   IO-APIC-fasteoi   acpi
 20:        826     748020   IO-APIC-fasteoi   nvidia
 22:          0          3   IO-APIC-fasteoi   ehci_hcd:usb2, ehci_hcd:usb4
 23:        437     175388   IO-APIC-fasteoi   ohci_hcd:usb1, ohci_hcd:usb3
314:       2891    1330645   PCI-MSI-edge      eth1
315:          0          0   PCI-MSI-edge      cx23885[0]
316:        258     115865   PCI-MSI-edge      HDA Intel
317:        286     118802   PCI-MSI-edge      ahci
NMI:          0          0   Non-maskable interrupts
LOC:     977113    1020994   Local timer interrupts
RES:     327021      99771   Rescheduling interrupts
CAL:       1408        972   function call interrupts
TLB:      11275       4795   TLB shootdowns
TRM:          0          0   Thermal event interrupts
THR:          0          0   Threshold APIC interrupts
SPU:          0          0   Spurious interrupts
ERR:          1

I tried several things so far:
Debian kernel image 2.6.25-2-amd64 (2.6.25-5 and 2.6.25-7)
Ubuntu 8.04 with kernel 2.6.24-16
self-compiled 2.6.25.x (with x in nothing to 5), with and without -rt patches
self-compiled 2.6.26-rc5 to 2.6.26 final
latest alsa-driver 1.0.17rc2, 1.0.17-rc3 and 1.0.17
alsa-library versions 1.0.16 and 1.0.17

all these versions give the similar distorted output.

please find the alsa-info output here:
(previously posted info:

attached is my latest kernel setup (2.6.26, alsa driver modules now replaced by version 1.0.17).

Please tell me your suggestions what the problem may be or how I could debug the problem.
Thanks very much.

Hans-Frieder Vogt                 e-mail: hfvogt <at> gmx .dot. net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.gz
Type: application/x-gzip
Size: 14916 bytes
Desc: not available
Url : http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20080720/6ca8b5b7/attachment-0001.gz 

More information about the Alsa-devel mailing list