[alsa-devel] [Alsa-user] is this card supported by ALSA?

Landis McGauhey b3zdomny at hotmail.com
Fri Jul 18 19:46:34 CEST 2008

> Date: Fri, 18 Jul 2008 18:31:14 +0200
> From: rene.herman at keyaccess.nl
> To: b3zdomny at hotmail.com
> CC: tiwai at suse.de; alsa-user at lists.sourceforge.net; alsa-devel at alsa-project.org; alsa at sc8-sf-spam2.sourceforge.net
> Subject: Re: [Alsa-user] is this card supported by ALSA?
> On 16-07-08 20:50, Rene Herman wrote:
> > Moreover, the AC97 codec seems integrated in the EV1938. Just found a
> > patch for FreeBSD following up a similar report for your card. Will
> > look at it tomorrow.
> Nothing interesting. Ready to give up on this. There is a communication 
> problem with the AC97 codec and that's the kind of thing which is almost 
> impossible to debug via email, especially since apparently this is not 
> different for the OSS driver; it's also not getting back a valid ID at 
> least.
> I do wonder a bit if that might mean that the only difference is the 
> ALSA "mute by default" behaviour. The attached patch does away with the 
> default muting of the AC97 controls. You'd apply it as before (after 
> reverting the previous 2 patches as written earlier), "make", "make 
> modules_install" and then load snd-ens1371:
> # modprobe -r es1371
> # modprobe -r snd-ens1371
> # modprobe snd-ens1371
> and then "aplay foo.wav" (without first starting alsamixer). If no 
> sound, adjust levels in alsamixer, retry aplay, if no sound, reboot (to 
> get the card to a startup state) and retry after the above 3 modprobes.
> If for some unimagineable reason you still need "alsaconf" instead of 
> just modprobe snd-ens1371 to load the driver, adjust accordingly. Have 
> no idea why that would be the case.
> If as expected you still have no sound I give up. Stared at this stuff, 
> but am not seeing anything stand out. If you ever decide to replace the 
> card and can find an ALSA developer in your neighbourhood to donate it 
> to that could be interesting. I've never seen an EV1938 locally here; 
> distribution is probably limited to the US.
> Rene.

Thank you so much, Rene.  I will do these procedures, but in the meantime I have OSS in full swing.  Do I need to do something to turn off or uninstall OSS before proceeding with the above procedures?  Thank you.

Best regards from North-Central California where the forest fires are increasingly under control and our skies are finally more clear,


Time for vacation? WIN what you need- enter now!

More information about the Alsa-devel mailing list