[alsa-devel] HDMI v. ICH8 on Dell XPS M1330

Tellman, Steven Steven.Tellman at idt.com
Fri Feb 29 15:48:12 CET 2008


	On the XPS M1330 (and XPS M1530) the SPDIF pin of the 9228 is
hooked to the HDMI as these laptops were made before the HDMI portion
had their own audio codec portion of the transceiver. So technically, it
should be pretty simple ;) 

IDT PC Audio Demo/Linux/Test

-----Original Message-----
From: Takashi Iwai [mailto:tiwai at suse.de] 
Sent: Friday, February 29, 2008 5:57 AM
To: Armando Di Cianno
Cc: Tellman, Steven; alsa-devel at alsa-project.org
Subject: Re: [alsa-devel] HDMI v. ICH8 on Dell XPS M1330

At Thu, 28 Feb 2008 20:29:06 -0500,
Armando Di Cianno wrote:
> On Thu, 2008-02-28 at 12:55 -0800, Tellman, Steven wrote:
> > Notice we use the "Other Digital" as the jack. Is that possibly
> > causing
> > a problem? IEC958 shows up, but doesn't provide output to HDMI
> > (that I've tested).
> At a user level, this is definitely what I've experienced.
> Are there any suggestions for testing if my current ALSA
> install /should/ work, or how to find out if something is
> or will simply not work?
> I will gladly try any suggestions, thoroughly.  Thanks.

It's a bit hard to judge right now.  So far, many HDMI devices seem
not working even though it appears set up properly.  I've heard that
ATI HDMI devices are working, but others are not well, e.g. on some
devices only left channel is output and on others silent.

Moreover, I'm not pretty sure whether HDMI is connected from the
digital out of STAC codec.  On many devices (e.g. ASUS ones), there is
a dedicated codec for the HDMI transmitter.

So, right now, it's total lack of (hardware) information,

We may try some verbs for HDMI that are not used in the current ALSA
code, at least.  These verbs were extended later...


More information about the Alsa-devel mailing list