[alsa-devel] snd-hda-intel AD1981 - the microphone doesn't work

Robert Gonciarz ruppertus at gmail.com
Tue Feb 12 18:11:28 CET 2008

Hi, I'm trying to activate a microphone (I have just external one) in my 
HP NX7300 (RU374ES) notebook (it has two jacks without internal mic) for 
six months. Alsamixer says that it's AD1981 chipset.

The sound works great execept two things:
- it's too silent when I set almost the maximum level (if you compare it 
with Windows XP driver) - but it's not so bad. It is said that a tothem 
can change some hidden settings to make it louder.

- the microphone doesn't work even though I setted it in alsamiser (the 
settings: <capture tab> the "Mic" is red, "Mic boss" is setted with 
67/67, "Capture" 80/80, Mix is blue and "-----", "Digital" 62/62, 
"Docking-" is blue and "----", "Internal" 67/67.
The mic doesn't capture any voice at all.

I was trying to load the module with different names: default, hp and 
toshiba works but the mic still doesn't work.

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High 
Definition Audio Controller (rev 01)

lspci -nv
00:1b.0 0403: 8086:27d8 (rev 01)
	Subsystem: 103c:30a2
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f4580000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel

It was tested with snd-hda-intel module from the lastest sources from 
your website: alsa-driver-1.0.16rc2.

I'm using kernel. At the begining I tried to compile the kernel 
with a module which was included to it (it was working without a mic) 
and then I compiled the external module from your web.

It was tested with many other kernels.

Can you check it please? If you need more information just email me back.


More information about the Alsa-devel mailing list