[alsa-devel] Seeking help for ALC269 with ALSA-Driver-1.0.15

Sailesh Tammannagari Sailesh_Tammannagari at phoenix.com
Mon Dec 29 18:24:38 CET 2008


        I have recently started working on ALSA. I have gone through few documents from ww.alsa-project.org and managed to fix few bugs that I came across in the recent past.
Now I have ASUS NETBOOK EEE PC 1000H with realtek codec ALC269. My base kernel version is 2.6.18 and alsa driver version is alsa-driver-1.0.15. The problem I am facing is

1. when I play aplay <filename.wav> the audio quality is very low.
2. when I use amixer -c 0 I get the dump please refer the attached amixer-dump-asus.txt.
3. I have attached asus-proc-dump.txt from     #cat /proc/asound/card0/codec#0.

Attached are the files for your reference. I tried running alsa-info.sh but it was not getting executed on my NETbook.

I tried changing sound/pci/had/patch_realtek.c but could not see much improvement. I am seeking your help in resolving such issues. Please also let me know if I can change the settings on the fly and check if the volume is increasing or not.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: asus-proc-dump.txt
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20081229/1504a816/attachment.txt 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: amixer-dump-asus.txt
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20081229/1504a816/attachment-0001.txt 

More information about the Alsa-devel mailing list