[alsa-devel] No HDMI audio on Asus P5Q-EM

Chris Pimlott pimlottc at gmail.com
Sun Dec 14 18:17:54 CET 2008

Forgot to join the list first, also here is the bugtrack issue:

On Thu, Dec 11, 2008 at 3:41 PM, Chris Pimlott <pimlottc at gmail.com> wrote:

> I have an Asus P5Q-EM motherboard, with Intel G45 chipset and Realtek ALC
> 1200 integrated audio, with HDMI output. (Specifications:
> http://www.asus.com/products.aspx?modelmenu=2&model=2413&l1=3&l2=11&l3=761&l4=0)<http://www.asus.com/products.aspx?modelmenu=2&model=2413&l1=3&l2=11&l3=761&l4=0%29>[
> ^<http://www.asus.com/products.aspx?modelmenu=2&model=2413&l1=3&l2=11&l3=761&l4=0%29>
> ]
> The analog output has always worked fine (from the default Mythbuntu
> install), but I do not get any output when trying to use the HDMI. I am
> testing with aplay: "aplay -D plughw:0,3
> /usr/share/sounds/alsa/Front_Center.wav". plughw:0,1 with the same command
> works (on analog out).
> I see three devices, "IEC958", "IEC958 Default PCM" and "IEC958 1", which
> are all unmuted. I have tried flipped the copyright setting with "iecset -n
> 1 copy on" but that has made no difference.
> I have tried a number of versions, including the stock 2.6.27 kernel
> package shipped in Mythbuntu, alsa-1.0.18 and alsa-1.0.18a, as well as
> version of the sound-2.6 from 2008-11-23 and today. The most recent I'm
> trying is sound-2.6 version is b13a9d80db0f1f4ace2863e8824a3d3299730d0a.
> I've notice there's been a fair amount of updates to this area of the
> snd_hda_intel driver, and some changes to how the device has shown up in
> recent releases. Should I even expect this to work, or is it still
> "in-progress"?  Thanks.
> Chris Pimlott

More information about the Alsa-devel mailing list