[alsa-devel] Swissonic TS22PCI / Teratec Phase 22 / driver problems with ice1724

Manuel Schneider manuel.schneider at kanal-ratte.de
Wed Aug 27 19:15:45 CEST 2008

Good news:
It works now.

But I still suspect a bug / an incompatibilty in the driver.

Today, I checked playback - that worked perfectly. Then I tried arecord / 
aplay - perfectly.

Then I switched the encoder (darkice) from OSS to alsa - now that works to. I 
rechecked OSS - it's definitely the OSS compatibility layer which does not 
work - but worked fine before the card was replaced.

I also found another problem but this might be a darkice bug but I still want 
to discuss it, because I had this problem with other cards, too:

When using alsa in darkice, setting the samplerate to 44100 in darkice as well 
as the mixer the samplerates still do not match. The 44100 Hz stream is "too 
fast", resulting in mickey mouse voices and lag every few seconds.
This issue can be solved by setting defaults.pcm.dmix.rate to 44100 in 
Do you have an idea why this problem is here? Is it truely a darkice bug, as 
it doesn't set the samplerate of the sounddevice properly or where is the 

Greets and thanks für the help,

Kanal Ratte 104,5 MHz
Freies Radio Schopfheim

Hauptstrasse 82
79650 Schopfheim

Tel: +49 7622 6692-53
Fax: +49 7622 6692-54

More information about the Alsa-devel mailing list