[alsa-devel] intel8x0 / ALC655 no-capture solved

Takashi Iwai tiwai at suse.de
Tue May 15 12:50:10 CEST 2007

At Wed, 9 May 2007 23:07:11 +0200 (CEST),
Vegard Nossum wrote:
> Hello,
> I've successfully debugged a problem I've had with being unable to record
> anything from microphones or line-in. Detailed information about the bug
> along with a temporary work-around can be found here:
> http://bugtrack.alsa-project.org/alsa-bug/view.php?id=3066
> Now I'd just like to inform about the presence of the bug (at least I'm
> pretty sure it's a bug), and that it's solved by the means of a
> work-around. I'd be very happy to see a fix in the *code* for this,
> however. I'd even like to try it myself (heck, it's just a register
> write), but I'm not certain WHERE/WHEN to make the write, under which
> conditions, and for which range of cards (ie. is it specific to the ALC655
> or ALC*, or perhaps Realtek chips, or should the fix be made for the Intel
> driver, or all AC'97 cards?). Guidance would be appreciated :) Maybe it's
> even as easy as a card config option, but I wouldn't know.

Finally have some time to reach this report...
We still need to check whether it's really a driver bug or a user
problem.  Please test the following:

- Check the generated file via "alsactl -f somefile store".
  Attach this file.
- This should contain "Capture Source" enum item.  You can modify that
  file (change value.0 and value.1), then run
	alsactl -f somefile restore
  to put the value.
- Look at ac97#0-0+regs proc and check whether the register 0x1a is
  changed by that.
- Finally test the PCM recording via hw:0,0.

The appearance on alsamixer is somehow confusing.  It appears not as a
"Capture Source" but individual items like "Mic", "Line", etc on
capture mode.  Then you can choose it by pressing a space key.  Since
this is a mux, another selected source will be automatically



More information about the Alsa-devel mailing list