[alsa-devel] intel8x0 / ALC655 no-capture solved

Vegard Nossum vegard at peltkore.net
Wed May 9 23:07:11 CEST 2007


I've successfully debugged a problem I've had with being unable to record
anything from microphones or line-in. Detailed information about the bug
along with a temporary work-around can be found here:

Now I'd just like to inform about the presence of the bug (at least I'm
pretty sure it's a bug), and that it's solved by the means of a
work-around. I'd be very happy to see a fix in the *code* for this,
however. I'd even like to try it myself (heck, it's just a register
write), but I'm not certain WHERE/WHEN to make the write, under which
conditions, and for which range of cards (ie. is it specific to the ALC655
or ALC*, or perhaps Realtek chips, or should the fix be made for the Intel
driver, or all AC'97 cards?). Guidance would be appreciated :) Maybe it's
even as easy as a card config option, but I wouldn't know.


Kinds regards,
Vegard Nossum

PS: I'm not on the list, so please CC any replies.

More information about the Alsa-devel mailing list