[alsa-devel] Alsa 1.0.13 (and others) does not work on ALC880

Takashi Iwai tiwai at suse.de
Tue Jun 12 11:35:05 CEST 2007

At Tue, 12 Jun 2007 00:51:48 -0500 (CDT),
acallan.alsa at ugnet.org wrote:
> Yes, I had tried it, and it did not work.  However, I hadn't grasped what
> you were trying to accomplish with it.  The problem was that
> hda_set_power_state() still called snd_hda_get_sub_nodes() on the modem
> codec before looping over the calls to get_wcaps(), and
> snd_hda_get_sub_nodes() is the function causing problems for my chip.
> The following patch works for me, and I think it accomplishes what you
> wanted.

Hm, then your modem codec doesn't follow the compliance.  The
subordinate node count parameter must be supported by any codecs,
according to HD-audio specification.
I suppose your modem has never worked?

If so, the right way to achieve it is to simply deactivate the modem
codec chip, e.g. by creating a blacklist, rather than disabling the
necessary functionalities.


More information about the Alsa-devel mailing list