[alsa-devel] Intel HDA Driver - Bug

Takashi Iwai tiwai at suse.de
Thu Jul 26 19:16:33 CEST 2007

At Thu, 26 Jul 2007 18:14:03 +0100,
Steven King wrote:
> Hi Takashi,
> I have grabbed the source tree: hg clone http://hg.alsa-project.org/alsa-kernel , hg
> clone http://hg.alsa-project.org/alsa-driver
> I compiled the module and reloaded it. The main speaker and headphones work (with HP
> jack detect), however the mic is still not working (a mic jack).  In alsamixer I get:
> ADCMux, InMux and InVol, I turned these all up to full and tried using
> gnome-sound-recorder to record sound, no luck. With Digital Input Source ->
> What can I do to work out the correct input device? I think that no mic input is
> detected during autoconfiguration.

Well, I'm not sure whether the recording works on _all_ mac models
there.  It was confirmed to work at least on some models, but not on
every model.

Anyway, let's sort out the possible mixer setting problem.
Please attach the contents of /proc/asound/card0/codec#* (for audio
codec) and the generated file via "alsactl -f somefile store" for
further analysis.


More information about the Alsa-devel mailing list