[alsa-devel] Intel HDA digital out distortion

Ingmar Stieger alsauser at stiegerhs.de
Tue Jul 24 11:28:25 CEST 2007

Hi Matthias,

Matthias Dahl wrote:

> That makes two of us. I've reported similar problems a few weeks back. So the 
> thread "snd-hda-intel, AD 1988b: SPDIF output not working correctly, volume 
> low for analog output" maybe of interest to you too. (I posted a similar 
> patch just a few minutes before your's by the way -g-)

I've read through your thread, and I think we might have two seperate problems
with this chip ? I am not getting any noise over SPDIF when no sound is
playing, but it will inevitably be distorted at any volume level and mixer
settings if sound is played through aplay or mplayer. I have not tried with
dts, only with wave files, by the way.

Looking at the functional diagram, and trying to mute the various amps that
might have something to do with this, then led to the 0x1D one that I mentioned.

Analog out seems to be fine with the stock drivers for me, altough I did not
compare the volume level with the levels of a Windows driver. At least it is as
loud as my CD player, so I'd say it is ok. It also sounds clean with the stock
drivers. No problem here.

> Could you please tell me what board you have...? If you play back analog sound 
> through spdif, do you hear "distortions" in the background like bass-like low 
> frequency pumping and so on...?

The board came pre-installed in a bare-bone system, so I only know that it is
from ASUS and whatever mainboard they put into their Pundit P2 system. The
chipset is a Intel 945G with ICH7.

I can not discern any special background noise, since the distortion is so loud
that any background noise that might be there is not audible.


More information about the Alsa-devel mailing list