[alsa-devel] Install of alsa 1.0.14.final on Fedora 7

tdavis at dsl-only.net tdavis at dsl-only.net
Sat Jul 14 09:09:31 CEST 2007

Quoting stan <stanl at cox.net>:

> On Fri, 13 Jul 2007 08:53:47 -0700
> tdavis at dsl-only.net wrote:
>> For RPM based systems, I have a build environment for the drivers,
>> libs, and utils packages at
>> http://members.dsl-only.net/~tdavis/my-build.tar.bz2.  You need to
>> be root to build them, but they won't interfere with your rpm
>> distribution.  THe driver rpm will also make a backup of your
>> current drivers prior to installation.
>> Tobin
> Hi Tobin,
> I unpacked the archive and typed make.  It created 4 RPMs.
> Two of them installed, alsa-lib and alsa-lib-devel.  When I run a test
> on the drivers rpm, there are conflicts with the kernel headers already
> on the box.  And I have no sound now, except in the audio configuration
> screen which is using the 14.rc3 packages.  The packages are named with
> rh7 instead of fc7 as well.
> Do I have to run make install to get everything working, or is the
> header incompatability in the drivers a show stopper?
> Thanks.
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> http://mailman.alsa-project.org/mailman/listinfo/alsa-devel

I'll have to look at the rpm build process to see why they are named  
RH7 instead of FC7.  To install, you should just type "audio_install".

If there is a conflict, just type "rpm -Uvh <package> --force".

More information about the Alsa-devel mailing list