[alsa-devel] Realtek ALC883 support on Albatron KI690-AM2 motherboard

Takashi Iwai tiwai at suse.de
Mon Dec 3 16:31:10 CET 2007

At Sun, 2 Dec 2007 16:08:32 -0500,
Andrew Paprocki wrote:
> Hello everyone,
> I'm currently trying to get the ALC883 on the Albatron KI690-AM2
> motherboard working under ALSA and I'm running into problems with some
> of the ports. From looking at the patch_realtek.c file inside the
> intel_hda driver, it appears there are many variants of hookups to
> this chipset which all require some manual configuration in the
> driver. I've tried what appears to be the closest match
> (ALC883_6ST_DIG or 6stack-dig), but it still does not enable all of
> the ports.
> The motherboard webpage is here:
> http://www.albatron.com.tw/English/product/mb/pro_detail.asp?rlink=Specification&no=239
> The board has two audio stacks on the back panel. Facing the jack
> inputs, the left-hand stack contains:
>     <S/PDIF output>
>     <TOSLINK w/ green cover>
> Next to that stack is a larger 6-stack with the following configuration:
>     <blue> <black>
>     <green> <pink>
>     <grey> <TOSLINK w/ pink cover>
> The box is running a stock debian 2.6.18-4-486 kernel.

First of all, try the very latest ALSA version (from HG repo) if you
want to debug HD-audio stuff.  It's the most actively changed part in
ALSA drivers.  2.6.18 is way too old as a reference.  Also you should
build the driver with debug option (in the case of alsa-driver tree,
pass --with-debug=full to configure).

If the latest version still doesn't work (with all available models), 
then check /proc/asound/card0/codec#* files.

(Anyway, I'll be on vacation from tomorrow, so cannot work on your
 problem.  Hopefully this will interest other guys...)


More information about the Alsa-devel mailing list