[alsa-devel] Unable to open plughw:0,0 from user program.

Takashi Iwai tiwai at suse.de
Thu Aug 23 21:38:46 CEST 2007

At Thu, 23 Aug 2007 11:44:56 -0700,
stan wrote:
> Hi,
> I am unable to use plughw:0,0 as a device string while calling
> err = snd_pcm_open (&alsa_dev, hw_from_default, SND_PCM_STREAM_PLAYBACK, 0);
> The same call works with hw_from_default == 'default', but fails when it 
> is 'plughw:0,0'.
> The error is
> cannot open audio device "plughw:0,0" (Device or resource busy)

Maybe the devce is really in use?
Try "fuser /dev/snd/*"

> I am using the latest snapshot of alsa-lib, alsa-lib20070821.  I tried 
> debugging but I cannot trace through the macros.  As near as I can tell 
> there have been no changes to alsa.conf, and this worked just fine 
> before the latest upgrade alsa package alsa-lib.1.0.14-3
> Is this a deliberate change in alsa that is known about, and is there a 
> way to still get the functionality?

The old library binary might still remain.  Some distros install
libasound in /lib (or /lib64), instead of /usr/lib (or /usr/lib64).


More information about the Alsa-devel mailing list