[alsa-devel] Unable to open plughw:0,0 from user program.

stan stanl at cox.net
Thu Aug 23 20:48:01 CEST 2007

stan wrote:
> Hi,
> I am unable to use plughw:0,0 as a device string while calling
> err = snd_pcm_open (&alsa_dev, hw_from_default, 
> The same call works with hw_from_default == 'default', but fails when 
> it is 'plughw:0,0'.
> The error is
> cannot open audio device "plughw:0,0" (Device or resource busy)
> I am using the latest snapshot of alsa-lib, alsa-lib20070821.  I tried 
> debugging but I cannot trace through the macros.  As near as I can 
> tell there have been no changes to alsa.conf, and this worked just 
> fine before the latest upgrade alsa package alsa-lib.1.0.14-3
> Is this a deliberate change in alsa that is known about, and is there 
> a way to still get the functionality?
> Thanks.
Forgot to mention that this is on Fedora Rawhide with a 2.6.23 kernel.  
Want to see if it is normal in the latest versions of alsa before I 
pursue it through bugzilla with Fedora.

More information about the Alsa-devel mailing list