No subject

Sat Apr 21 06:42:51 CEST 2007

point on.  The note above the function azx_single_send_cmd() makes it
clear that this function should not be used for normal operation.  And,
indeed, after this point, calls to the chip for the audio codec seem to
return bogus values (as could be seen in the Default PCM and Node sections
of the Codec information at

So, I have a few questions:
1)  Does it make sense that the modem codec would have 39 fg nodes?
2)  Does it make sense that the switch to single_cmd mode would possibly
be the cause of the bogus values being returned later?  (I haven't really
traced much past this point since that comment about azx_single_send_cmd
seemed to make it clear that I was already in trouble by this point.)
3)  What other things would it be helpful to look at to try to chase this
problem further?


accallan at

On Sat, 19 May 2007, Takashi Iwai wrote:

> At Sat, 19 May 2007 02:08:14 -0500 (CDT),
> Andrew Callan wrote:
> >
> > I have been without sound using Fedora Core ever since the 2.6.16 or
> > 2.6.17 kernel update (2.6.16 crashed during initialization, so I could not
> > tell whether sound worked or not).  It had worked well through the 2.6.15
> > Fedora kernels.  I finally sat down tonight to work the problem as hard as
> > I could and happened upon Eric and Tobin's timely exchange.
> >
> > First, simply adding probe_mask=1 to the snd-hda-intel options worked for
> > me as well; I did not end up having to specify a specific model.
> >
> > Second, I too was seeing a LONG hang when trying to do:
> > cat /proc/asound/card0/codec#0
> > but now with the probe_mask=1, I do not see this.
> >
> > If it helps, the output for my system is at
> >
> > If it makes any difference, I'm not sure which model I had specified on
> > the modprobe line at the time I captured this output.
> >
> > One thing I do notice is that after adding probe_mask=1, aplay -l does not
> > show the Si3054 Modem which shows up in the alsa-info output.
> >
> > Thanks for the help you gave in the thread with Eric.
> >
> > Andrew
> Interesting.  I've seen similar reports that probe_mask helps.
> Do you disable the modem codec on BIOS or is it enabled?
> If this happens even though it's enabled on BIOS, we'd need a
> blacklist of non-working devices, or a more robust probing routine...
> Takashi
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at

More information about the Alsa-devel mailing list