[alsa-devel] No sound with ATI SB450

Ben DiDonc ben.didonc at gmail.com
Sat Apr 21 06:56:34 CEST 2007

I have a toshiba A100 (see attached file lspci-nnv) with a ATI SB450.
Sound worked fine with kernel 2.6.17 and alsa 1.0.12rc1 (ubuntu edgy).
I just did a fresh install of ubuntu feisty (kernel 2.6.20, alsa
1.0.14rc1) and the only mixer settings available are those of the
modem, named off-hook and caller-id (see output of amixer, aplay -l ,
and the rest in attached file output_feisty)

I decided to upgrade alsa-driver and alsa-lib to 1.0.14rc2. after
downloading the package, I unloaded all sound related modules
(everything with "snd_" in it) in the right order and did:
./configure --with-oss=yes --with-cards=hda-intel;make; sudo make
install; sudo modprobe snd_hda_intel
A minor improvement: the mixer now shows controls for both the modem
and the sound card (see output_after_upgrade_to_rc2), but
unfortunately, there is still no sound coming out of those speakers
(even though alsamixer shows control for PCM and the rest...).

Finally, I downloaded alsa-driver-1.0.14rc3 and gave it a shot. This
time again, only modem related settings appeared in alsamixer, and no
sound card stuff (see aplay and amixer in
output_after_upgrade_to_rc3), and no sound either.

Does anyone know how to get some sound out of these speakers (given
that it used to work with alsa1.0.12rc1...) ?

Thanks for your help

More information about the Alsa-devel mailing list