[alsa-devel] Fwd: No sound with ATI SB450

Ben DiDonc ben.didonc at gmail.com
Sat Apr 21 12:27:46 CEST 2007

I downloaded and installed alsa-driver, alsa-lib and alsa-utils, but still
no sound coming out of those speakers...
I ran alsa-info.sh and the results are at http://pastebin.ca/451128
I am clueless as to what to do next, but I m ready to try anything.
 Any help would be greatly appreciated.

On 4/21/07, Tobin Davis < tdavis at dsl-only.net> wrote:
>  Try downloading a current daily snapshot from ftp://ftp.suse.com/pub/projects/alsa/snapshot/
> .
> There was an issue with the ATI HD Audio detection that was fixed after
> 14rc3 was released.
> Tobin
> On Sat, 2007-04-21 at 16:00 +1000, Ben DiDonc wrote:
> The output of alsa-info.sh is available at http://pastebin.ca/451007
>  On 4/21/07, *Tobin Davis* < tdavis at dsl-only.net> wrote:
>  Could you download an run http://bulletproof.servebeer.com/alsa/scripts/alsa-info.sh
> , then post the resulting link?  This will help determine what setup you
> have.
> Tobin Davis
> On Sat, 2007-04-21 at 14:56 +1000, Ben DiDonc wrote:
>   Hi I have a toshiba A100 (see attached file lspci-nnv) with a ATI SB450.
> Sound worked fine with kernel 2.6.17 and alsa 1.0.12rc1 (ubuntu edgy). I
> just did a fresh install of ubuntu feisty (kernel 2.6.20, alsa 1.0.14rc1)
> and the only mixer settings available are those of the modem, named off-hook
> and caller-id (see output of amixer, aplay -l , and the rest in attached
> file output_feisty) I decided to upgrade alsa-driver and alsa-lib to
> 1.0.14rc2. after downloading the package, I unloaded all sound related
> modules (everything with "snd_" in it) in the right order and did:
> ./configure --with-oss=yes --with-cards=hda-intel;make; sudo make install;
> sudo modprobe snd_hda_intel A minor improvement: the mixer now shows
> controls for both the modem and the sound card (see
> output_after_upgrade_to_rc2), but unfortunately, there is still no sound
> coming out of those speakers (even though alsamixer shows control for PCM
> and the rest...). Finally, I downloaded alsa-driver-1.0.14rc3 and gave it
> a shot. This time again, only modem related settings appeared in alsamixer,
> and no sound card stuff (see aplay and amixer in
> output_after_upgrade_to_rc3), and no sound either. Does anyone know how to
> get some sound out of these speakers (given that it used to work with
> alsa1.0.12rc1...) ? Thanks for your help Ben
>    _______________________________________________Alsa-devel mailing listAlsa-devel at alsa-project.orghttp://mailman.alsa-project.org/mailman/listinfo/alsa-devel
>    --
> Tobin Davis <tdavis at dsl-only.net>
>   --
> Tobin Davis <tdavis at dsl-only.net>

More information about the Alsa-devel mailing list