[PATCH v3 00/17] ASoC: Intel: haswell and broadwell boards update
Cezary Rojewski
cezary.rojewski at intel.com
Mon Jun 20 10:22:09 CEST 2022
A number of patches improving overall quality and readability of
haswell.c and broadwell.c source files found in sound/soc/intel/boards.
Both files are first renamed and only then actual changes are being
incrementally added. The respective names are: hsw_rt5640 and bdw_rt286
to match the pattern found in more recent boards.
Most patches bring no functional change - the more impactful patches at
are placed the end:
Refactor of suspend/resume flow for the bdw_rt286 board by dropping
dev->remove() in favour of card->remove() and adjust jack handling to
reduce code size slightly by implementing card_set_jack().
The last patch is removing of FE DAI ops. Given the existence of
platform FE DAI capabilities (either static declaration or through
topology file), this code is redundant.
Changes in v3:
- Patch 16/17 refactoring suspend/resume has been renamed to "Refactor
jack handling". Dropped the usage of card->remove() in favor of
link->exit() in that very patch
Changes in v2:
- fixed wording error in patch 02/17 so it correctly mentions
'haswell_rt5640', not 'broadwell_rt286'
- decided not to add kernel module names changes to this patchset so the
review is not complicated unnecessarily. Will send them separately
instead
Cezary Rojewski (17):
ASoC: Intel: Rename haswell source file to hsw_rt5640
ASoC: Intel: hsw_rt5640: Reword prefixes of all driver members
ASoC: Intel: hsw_rt5640: Reword driver name
ASoC: Intel: hsw_rt5640: Update code indentation
ASoC: Intel: hsw_rt5640: Update file comments
ASoC: Intel: hsw_rt5640: Improve probe() function quality
ASoC: Intel: hsw_rt5640: Improve hw_params() debug-ability
ASoC: Intel: Rename broadwell source file to bdw_rt286
ASoC: Intel: bdw_rt286: Reword prefixes of all driver members
ASoC: Intel: bdw_rt286: Reword driver name
ASoC: Intel: bdw_rt286: Update code indentation
ASoC: Intel: bdw_rt286: Update file comments
ASoC: Intel: bdw_rt286: Improve probe() function quality
ASoC: Intel: bdw_rt286: Improve hw_params() debug-ability
ASoC: Intel: bdw_rt286: Improve codec_init() quality
ASoC: Intel: bdw_rt286: Refactor jack handling
ASoC: Intel: bdw_rt286: Remove FE DAI ops
sound/soc/intel/boards/Kconfig | 4 +-
sound/soc/intel/boards/Makefile | 4 +-
sound/soc/intel/boards/bdw_rt286.c | 256 +++++++++++++
sound/soc/intel/boards/broadwell.c | 336 ------------------
sound/soc/intel/boards/haswell.c | 202 -----------
sound/soc/intel/boards/hsw_rt5640.c | 176 +++++++++
.../common/soc-acpi-intel-hsw-bdw-match.c | 6 +-
7 files changed, 439 insertions(+), 545 deletions(-)
create mode 100644 sound/soc/intel/boards/bdw_rt286.c
delete mode 100644 sound/soc/intel/boards/broadwell.c
delete mode 100644 sound/soc/intel/boards/haswell.c
create mode 100644 sound/soc/intel/boards/hsw_rt5640.c
--
2.25.1
More information about the Alsa-devel
mailing list