[PATCH 5/6] ASoC: ak4613: rename constraint to constraint_rates
Kuninori Morimoto
kuninori.morimoto.gx at renesas.com
Tue Apr 5 04:06:44 CEST 2022
From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
TDM support needs to use constraint_channels.
This patch renames current constraint to constraint_rates for it.
This is prepare for TDM support.
Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
---
sound/soc/codecs/ak4613.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/sound/soc/codecs/ak4613.c b/sound/soc/codecs/ak4613.c
index 73fae6ffe92b..2ec6313e823d 100644
--- a/sound/soc/codecs/ak4613.c
+++ b/sound/soc/codecs/ak4613.c
@@ -86,7 +86,7 @@ struct ak4613_interface {
struct ak4613_priv {
struct mutex lock;
- struct snd_pcm_hw_constraint_list constraint;
+ struct snd_pcm_hw_constraint_list constraint_rates;
struct work_struct dummy_write_work;
struct snd_soc_component *component;
unsigned int rate;
@@ -272,10 +272,11 @@ static void ak4613_hw_constraints(struct ak4613_priv *priv,
176400,
192000,
};
- struct snd_pcm_hw_constraint_list *constraint = &priv->constraint;
+ struct snd_pcm_hw_constraint_list *constraint;
unsigned int fs;
int i;
+ constraint = &priv->constraint_rates;
constraint->list = ak4613_rates;
constraint->mask = 0;
constraint->count = 0;
--
2.25.1
More information about the Alsa-devel
mailing list