[PATCH -next] ASoC: Intel: Skylake: use DEVICE_ATTR_RO macro

Cezary Rojewski cezary.rojewski at intel.com
Thu May 27 13:16:02 CEST 2021


On 2021-05-24 1:55 PM, YueHaibing wrote:
> Use DEVICE_ATTR_RO() helper instead of plain DEVICE_ATTR(),
> which makes the code a bit shorter and easier to read.
> 
> Signed-off-by: YueHaibing <yuehaibing at huawei.com>
> ---

Thanks for your input.

Reviewed-by: Cezary Rojewski <cezary.rojewski at intel.com>

Regards,
Czarek

>   sound/soc/intel/skylake/skl-nhlt.c | 6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/sound/soc/intel/skylake/skl-nhlt.c b/sound/soc/intel/skylake/skl-nhlt.c
> index 87c891c46291..64226072f0ee 100644
> --- a/sound/soc/intel/skylake/skl-nhlt.c
> +++ b/sound/soc/intel/skylake/skl-nhlt.c
> @@ -149,8 +149,8 @@ int skl_nhlt_update_topology_bin(struct skl_dev *skl)
>   	return 0;
>   }
>   
> -static ssize_t skl_nhlt_platform_id_show(struct device *dev,
> -			struct device_attribute *attr, char *buf)
> +static ssize_t platform_id_show(struct device *dev,
> +				struct device_attribute *attr, char *buf)
>   {
>   	struct pci_dev *pci = to_pci_dev(dev);
>   	struct hdac_bus *bus = pci_get_drvdata(pci);
> @@ -166,7 +166,7 @@ static ssize_t skl_nhlt_platform_id_show(struct device *dev,
>   	return sprintf(buf, "%s\n", platform_id);
>   }
>   
> -static DEVICE_ATTR(platform_id, 0444, skl_nhlt_platform_id_show, NULL);
> +static DEVICE_ATTR_RO(platform_id);
>   
>   int skl_nhlt_create_sysfs(struct skl_dev *skl)
>   {
> 


More information about the Alsa-devel mailing list