[PATCH v9 1/4] mfd: Add Rockchip rk817 audio CODEC support
Chris Morgan
macroalpha82 at gmail.com
Thu May 13 17:01:22 CEST 2021
On Mon, May 10, 2021 at 05:23:29PM +0100, Lee Jones wrote:
> On Wed, 05 May 2021, Chris Morgan wrote:
>
> > From: Chris Morgan <macromorgan at hotmail.com>
> >
> > Add rk817 codec support cell to rk808 mfd driver.
> >
> > Tested-by: Maciej Matuszczyk <maccraft123mc at gmail.com>
> > Signed-off-by: Chris Morgan <macromorgan at hotmail.com>
>
> Nit: These should be chronological.
Acknowledged. I will make sure to do this if a v10 is necessary.
>
> > ---
> > Changes in v9:
> > - Add cover letter.
> > - Remove documentation for interrupt parent per Rob Herring's request.
> > - Remove unused MODULE_DEVICE_TABLE to fix a bug identified by kernel test
> > robot.
> > Changes in v8:
> > - Added additional documentation for missing properties of #sound-dai-cells,
> > interrupt-parent, and wakeup-source for mfd documentation.
> > - Corrected order of elements descriptions in device tree documentation.
> > - Changed name of "mic-in-differential" to "rockchip,mic-in-differential".
> > - Changed name of sound card from "rockchip,rk817-codec" to "Analog".
> > - Removed unused resets and reset-names from the i2s1_2ch node.
> > Changes in v7:
> > - Removed ifdef around register definitions for MFD.
> > - Replaced codec documentation with updates to MFD documentation.
> > - Reordered elements in example to comply with upstream rules.
> > - Added binding update back for Odroid Go Advance as requested.
> > - Submitting patches from gmail now.
> > Changes in v6:
> > - Included additional project maintainers for correct subsystems.
> > - Removed unneeded compatible from DT documentation.
> > - Removed binding update for Odroid Go Advance (will do in seperate series).
> > Changes in v5:
> > - Move register definitions from rk817_codec.h to main rk808.h register
> > definitions.
> > - Add volatile register for codec bits.
> > - Add default values for codec bits.
> > - Removed of_compatible from mtd driver (not necessary).
> > - Switched to using parent regmap instead of private regmap for codec.
> > Changes in v4:
> > - Created set_pll() call.
> > - Created user visible gain control in mic.
> > - Check for return value of clk_prepare_enable().
> > - Removed duplicate clk_prepare_enable().
> > - Split DT documentation to separate commit.
> > Changes in v3:
> > - Use DAPM macros to set audio path.
> > - Updated devicetree binding (as every rk817 has this codec chip).
> > - Changed documentation to yaml format.
> > - Split MFD changes to separate commit.
> > Changes in v2:
> > - Fixed audio path registers to solve some bugs.
> >
> > drivers/mfd/rk808.c | 85 +++++++++++++++++++++++++++++++++++++++
> > include/linux/mfd/rk808.h | 81 +++++++++++++++++++++++++++++++++++++
> > 2 files changed, 166 insertions(+)
> >
> > diff --git a/drivers/mfd/rk808.c b/drivers/mfd/rk808.c
> > index ad923dd4e007..9231209184e0 100644
> > --- a/drivers/mfd/rk808.c
> > +++ b/drivers/mfd/rk808.c
> > @@ -65,6 +65,7 @@ static bool rk817_is_volatile_reg(struct device *dev, unsigned int reg)
> > switch (reg) {
> > case RK817_SECONDS_REG ... RK817_WEEKS_REG:
> > case RK817_RTC_STATUS_REG:
> > + case RK817_CODEC_DTOP_LPT_SRST:
> > case RK817_INT_STS_REG0:
> > case RK817_INT_STS_REG1:
> > case RK817_INT_STS_REG2:
> > @@ -163,6 +164,11 @@ static const struct mfd_cell rk817s[] = {
> > .num_resources = ARRAY_SIZE(rk817_rtc_resources),
> > .resources = &rk817_rtc_resources[0],
> > },
> > +#ifdef CONFIG_SND_SOC_RK817
> > + {
> > + .name = "rk817-codec",
> > + },
> > +#endif
>
> No #ifery please.
>
> Just replace it with a comment.
>
> If no associated driver exists, it just won't match/bind.
I did the "if" here because I noticed that if I have a rk817 and do not
utilize the codec I receive a dmesg warning. I put the if here to silence
it in the event that someone was using this PMIC but didn't want to use
the audio codec. I will make the change if you say so though, but I just
want to confirm that it's acceptable to have a warning for all rk817s
that do not use the codec about a missing codec. The hardware is always
present, I just can't say for certain it will always be used.
Thank you.
>
> --
> Lee Jones [李琼斯]
> Senior Technical Lead - Developer Services
> Linaro.org │ Open source software for Arm SoCs
> Follow Linaro: Facebook | Twitter | Blog
More information about the Alsa-devel
mailing list