[PATCH 1/2] ASoC: soc-compress: tidyup STREAM vs COMPRESS
Kuninori Morimoto
kuninori.morimoto.gx at renesas.com
Thu Oct 29 00:23:58 CET 2020
Hi Pierre-Louis
Cc Mark
> > From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
> >
> > snd_soc_runtime_activate() and
> > snd_soc_dai_digital_mute() need SNDRV_PCM_STREAM_xxx
> > instead of SND_COMPRESS_xxx.
> >
> > These are bug but nothing happen because these are same value.
> >
> > enum {
> > SNDRV_PCM_STREAM_PLAYBACK = 0,
> > SNDRV_PCM_STREAM_CAPTURE,
> > ...
> > };
> >
> > enum snd_compr_direction {
> > SND_COMPRESS_PLAYBACK = 0,
> > SND_COMPRESS_CAPTURE
> > };
> >
> > This patch tidyup it.
>
>
> Could we use this instead:
>
> enum snd_compr_direction {
> SND_COMPRESS_PLAYBACK = SNDRV_PCM_STREAM_PLAYBACK,
> SND_COMPRESS_CAPTURE = SNDRV_PCM_STREAM_CAPTURE
> };
>
> Or remove this duplication completely and get rid of snd_compr_direction?
>
> I find it odd to convert two things that had no reason to be different
> in the first place.
Yes I agree with you.
I'm not sure why this duplication was created,
but my patch tried to make it sane.
If Mark can agree, I can post snd_compr_direction remove patch.
Thank you for your help !!
Best regards
---
Kuninori Morimoto
More information about the Alsa-devel
mailing list