[patch 08/22] ACPI: Convert to new X86 CPU match macros
Andy Shevchenko
andy.shevchenko at gmail.com
Fri Mar 20 15:47:10 CET 2020
On Fri, Mar 20, 2020 at 3:19 PM Thomas Gleixner <tglx at linutronix.de> wrote:
>
> The new macro set has a consistent namespace and uses C99 initializers
> instead of the grufty C89 ones.
>
> Rename the local macro wrapper to X86_MATCH for consistency. It stays for
> readability sake.
> + X86_MATCH_INTEL_FAM6_MODEL(ATOM_SILVERMONT, NULL),
> + X86_MATCH_INTEL_FAM6_MODEL(ATOM_AIRMONT, NULL),
> -#define ICPU(model) { X86_VENDOR_INTEL, 6, model, X86_FEATURE_ANY, }
> +#define X86_MATCH(model) X86_MATCH_INTEL_FAM6_MODEL(model, NULL)
Maybe we can do a generic macro to avoid all these ', NULL' repetitions?
--
With Best Regards,
Andy Shevchenko
More information about the Alsa-devel
mailing list