[alsa-devel] [PATCH 02/10] ASoC: soc-pcm: use dai_get_widget() at dpcm_get_be()
Kuninori Morimoto
kuninori.morimoto.gx at renesas.com
Thu Feb 13 05:26:13 CET 2020
From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
dpcm_get_be() has very duplicate code.
dpcm_get_be()
{
...
if (stream == SNDRV_PCM_STREAM_PLAYBACK) {
(1) /* code for Playback */
} else {
(2) /* code for Capture */
}
}
The difference between Playback (1) and Capture (2) code is pointer only
(= "playback_widget" or "caputre_widget").
OTOH, now we already has dai_get_widget() for it.
This means we can merge (1) and (2).
This patch do it and remove duplicated code.
Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
---
sound/soc/soc-pcm.c | 41 ++++++++++++-----------------------------
1 file changed, 12 insertions(+), 29 deletions(-)
diff --git a/sound/soc/soc-pcm.c b/sound/soc/soc-pcm.c
index a8adc8d06c05..e60dfbcf52b4 100644
--- a/sound/soc/soc-pcm.c
+++ b/sound/soc/soc-pcm.c
@@ -1246,47 +1246,30 @@ static struct snd_soc_pcm_runtime *dpcm_get_be(struct snd_soc_card *card,
struct snd_soc_dapm_widget *widget, int stream)
{
struct snd_soc_pcm_runtime *be;
+ struct snd_soc_dapm_widget *w;
struct snd_soc_dai *dai;
int i;
dev_dbg(card->dev, "ASoC: find BE for widget %s\n", widget->name);
- if (stream == SNDRV_PCM_STREAM_PLAYBACK) {
- for_each_card_rtds(card, be) {
+ for_each_card_rtds(card, be) {
- if (!be->dai_link->no_pcm)
- continue;
+ if (!be->dai_link->no_pcm)
+ continue;
- dev_dbg(card->dev, "ASoC: try BE : %s\n",
- be->cpu_dai->playback_widget ?
- be->cpu_dai->playback_widget->name : "(not set)");
+ w = dai_get_widget(be->cpu_dai, stream);
- if (be->cpu_dai->playback_widget == widget)
- return be;
+ dev_dbg(card->dev, "ASoC: try BE : %s\n",
+ w ? w->name : "(not set)");
- for_each_rtd_codec_dai(be, i, dai) {
- if (dai->playback_widget == widget)
- return be;
- }
- }
- } else {
-
- for_each_card_rtds(card, be) {
-
- if (!be->dai_link->no_pcm)
- continue;
+ if (w == widget)
+ return be;
- dev_dbg(card->dev, "ASoC: try BE %s\n",
- be->cpu_dai->capture_widget ?
- be->cpu_dai->capture_widget->name : "(not set)");
+ for_each_rtd_codec_dai(be, i, dai) {
+ w = dai_get_widget(dai, stream);
- if (be->cpu_dai->capture_widget == widget)
+ if (w == widget)
return be;
-
- for_each_rtd_codec_dai(be, i, dai) {
- if (dai->capture_widget == widget)
- return be;
- }
}
}
--
2.17.1
More information about the Alsa-devel
mailing list