[alsa-devel] [PATCH] ASoC: core: use list_del_init and move it back to soc_cleanup_component
Bard liao
yung-chuan.liao at linux.intel.com
Wed Sep 18 15:31:31 CEST 2019
commit a0a4bf57a977 ("ASoC: core: delete component->card_list in soc_remove_component only")
was trying to fix a kernel oops when list_del was called twice without
re-init the list. Use list_del_init() can solve it, too. Besides, it
will be more readable if we cleanup all component related resource at
soc_cleanup_component().
Suggested-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
Signed-off-by: Bard liao <yung-chuan.liao at linux.intel.com>
---
sound/soc/soc-core.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index aff4b4bf4d07..88978a3036c4 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -978,6 +978,7 @@ static void soc_cleanup_component(struct snd_soc_component *component)
/* For framework level robustness */
snd_soc_component_set_jack(component, NULL, NULL);
+ list_del_init(&component->card_list);
snd_soc_dapm_free(snd_soc_component_get_dapm(component));
soc_cleanup_component_debugfs(component);
component->card = NULL;
@@ -990,7 +991,7 @@ static void soc_remove_component(struct snd_soc_component *component)
return;
snd_soc_component_remove(component);
- list_del(&component->card_list);
+
soc_cleanup_component(component);
}
--
2.17.1
More information about the Alsa-devel
mailing list