[alsa-devel] [PATCH 15/15] ASoC: soc-core: add soc_unbind_aux_dev()

Sridharan, Ranjani ranjani.sridharan at intel.com
Thu Aug 8 18:45:30 CEST 2019


On Wed, Aug 7, 2019 at 11:03 PM Kuninori Morimoto <
kuninori.morimoto.gx at renesas.com> wrote:

>
> From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
>
> It is easy to read code if it is cleanly using paired function/naming,
> like start <-> stop, register <-> unregister, etc, etc.
> But, current ALSA SoC code is very random, unbalance, not paired, etc.
> It is easy to create bug at the such code, and it will be difficult to
> debug.
>
> soc-core.c has soc_bind_aux_dev(), but, there is no its paired
> soc_unbind_aux_dev(). This patch adds it.
>
Morimoto-san,
I'm not sure it quite improves readability to just have list_del in
unbind_aux_dev(). bin_aux_dev() does more than just adding to the
card_aux_list(). So in fact, I think  this change makes it look unbalanced.
The existing code for aux_dev looks quite similar to what bind_dai_link()
and remove_dai_link() do and they are quite intuitive.

Thanks,
Ranjani

>
> Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
> ---
>  sound/soc/soc-core.c | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
> index f8a5464..5e3b907 100644
> --- a/sound/soc/soc-core.c
> +++ b/sound/soc/soc-core.c
> @@ -1527,6 +1527,11 @@ static int soc_probe_link_dais(struct snd_soc_card
> *card,
>         return ret;
>  }
>
> +static void soc_unbind_aux_dev(struct snd_soc_component *component)
> +{
> +       list_del(&component->card_aux_list);
> +}
> +
>  static int soc_bind_aux_dev(struct snd_soc_card *card,
>                             struct snd_soc_aux_dev *aux_dev)
>  {
> @@ -1578,7 +1583,7 @@ static void soc_remove_aux_devices(struct
> snd_soc_card *card)
>                         if (comp->driver->remove_order == order) {
>                                 soc_remove_component(comp);
>                                 /* remove it from the card's aux_comp_list
> */
> -                               list_del(&comp->card_aux_list);
> +                               soc_unbind_aux_dev(comp);
>                         }
>                 }
>         }
> --
> 2.7.4
>
> _______________________________________________
> Alsa-devel mailing list
> Alsa-devel at alsa-project.org
> https://mailman.alsa-project.org/mailman/listinfo/alsa-devel
>


More information about the Alsa-devel mailing list