[alsa-devel] [PATCH 0/2][RFC] ASoC: add for_each_xxx_codec macro
Kuninori Morimoto
kuninori.morimoto.gx at renesas.com
Mon Sep 3 04:12:05 CEST 2018
Hi Mark
These are not so important patches.
But current code is using for loop for dai_link codecs
and rtd codec_dai, but I think using for_each_xxx
macro for these can be more readable.
These patches do it.
Kuninori Morimoto (2):
ASoC: add for_each_link_codecs() macro
ASoC: add for_each_rtd_codec_dai() macro
include/sound/soc.h | 11 ++
sound/soc/intel/boards/kbl_rt5663_max98927.c | 5 +-
.../soc/intel/boards/kbl_rt5663_rt5514_max98927.c | 5 +-
sound/soc/mediatek/mt8173/mt8173-rt5650-rt5514.c | 5 +-
sound/soc/mediatek/mt8173/mt8173-rt5650-rt5676.c | 5 +-
sound/soc/mediatek/mt8173/mt8173-rt5650.c | 5 +-
sound/soc/meson/axg-card.c | 11 +-
sound/soc/soc-core.c | 55 ++++----
sound/soc/soc-dapm.c | 14 +-
sound/soc/soc-pcm.c | 154 ++++++++++-----------
10 files changed, 133 insertions(+), 137 deletions(-)
--
2.7.4
More information about the Alsa-devel
mailing list