[alsa-devel] [PATCH] ALSA: pcm: Use krealloc() for resizing the rules array
Takashi Sakamoto
o-takashi at sakamocchi.jp
Tue Mar 13 15:17:56 CET 2018
Hi,
On Mar 13 2018 20:42, Takashi Iwai wrote:
> Just a minor simplification. Change from kcalloc() shouldn't matter
> as each array element is fully initialized.
>
> Signed-off-by: Takashi Iwai <tiwai at suse.de>
> ---
> sound/core/pcm_lib.c | 8 ++------
> 1 file changed, 2 insertions(+), 6 deletions(-)
I think this is a good simplification and preferable, too. Some local
variables in this block could be replaced by assignment but for
readability it's better to keep them as is, in my opinion.
Reviewed-by: Takashi Sakamoto <o-takashi at sakamocchi.jp>
> diff --git a/sound/core/pcm_lib.c b/sound/core/pcm_lib.c
> index a83152e7d387..f4a19509cccf 100644
> --- a/sound/core/pcm_lib.c
> +++ b/sound/core/pcm_lib.c
> @@ -1129,16 +1129,12 @@ int snd_pcm_hw_rule_add(struct snd_pcm_runtime *runtime, unsigned int cond,
> if (constrs->rules_num >= constrs->rules_all) {
> struct snd_pcm_hw_rule *new;
> unsigned int new_rules = constrs->rules_all + 16;
> - new = kcalloc(new_rules, sizeof(*c), GFP_KERNEL);
> + new = krealloc(constrs->rules, new_rules * sizeof(*c),
> + GFP_KERNEL);
> if (!new) {
> va_end(args);
> return -ENOMEM;
> }
> - if (constrs->rules) {
> - memcpy(new, constrs->rules,
> - constrs->rules_num * sizeof(*c));
> - kfree(constrs->rules);
> - }
> constrs->rules = new;
> constrs->rules_all = new_rules;
> }
Regards
Takashi Sakamoto
More information about the Alsa-devel
mailing list