[alsa-devel] [PATCH 00/39 v2] ASoC: add simple-card-core and standardize "simple" card
Kuninori Morimoto
kuninori.morimoto.gx at renesas.com
Tue May 31 10:56:55 CEST 2016
Hi Mark
These are v2 of simple-card cleanup patches.
Main purpose of these patches are
- cleanup simple-card
- rename rsrc-card to simple-dpcm-card
Main diff v1 <-> v2 are
- remove duplicate header patch
- rename simple-card-core.c -> simple-card-utils.c
- remove dpcm function from simple-card-utils.
- remove jack/pin/gpio/ function from simple-card-utils.
- remove widgets/route function from simple-card-utils.
I removed widgets/routing related function. it was very thin cosmetic functions.
About jack/pin/gpio on simple-card, it is still have same method,
but keeping it as static function.
dpcm related function too, it is keeping static.
1) - 3) cleaup patch as prepare
4) - 14) simple-card-utils
15) - 24) simple-card
25) - 36) rsrc-card
37) - 39) rsrc-card -> simple-dpcm-card
Kuninori Morimoto (39):
1) ASoC: rsrc-card: remove unused dai_num
2) ASoC: simple-card: use common PREFIX for each DT property
3) ASoC: simple-card: add new asoc_simple_jack and use it
4) ASoC: add new simple-card-utils.c
5) ASoC: simple-card-utils: add asoc_simple_card_parse_tdm()
6) ASoC: simple-card-utils: add asoc_simple_card_parse_dailink_name()
7) ASoC: simple-card-utils: add asoc_simple_card_parse_card_name()
8) ASoC: simple-card-utils: add asoc_simple_card_parse_card_prefix()
9) ASoC: simple-card-utils: add asoc_simple_card_parse_clk()
10) ASoC: simple-card-utils: add asoc_simple_card_parse_endpoint()
11) ASoC: simple-card-utils: add asoc_simple_card_init_dai()
12) ASoC: simple-card-utils: add asoc_simple_card_canonicalize_dailink()
13) ASoC: simple-card-utils: add asoc_simple_card_canonicalize_cpu()
14) ASoC: simple-card-utils: add asoc_simple_card_clean_reference()
15) ASoC: simple-card: use asoc_simple_card_parse_daifmt()
16) ASoC: simple-card: use asoc_simple_card_parse_clk()
17) ASoC: simple-card: use asoc_simple_card_parse_endpoint()
18) ASoC: simple-card: use asoc_simple_card_parse_tdm()
19) ASoC: simple-card: use asoc_simple_card_parse_card_name()
20) ASoC: simple-card: use asoc_simple_card_parse_dailink_name()
21) ASoC: simple-card: use asoc_simple_card_init_dai()
22) ASoC: simple-card: use asoc_simple_card_canonicalize_dailink()
23) ASoC: simple-card: use asoc_simple_card_canonicalize_cpu()
24) ASoC: simple-card: use asoc_simple_card_clean_reference()
25) ASoC: rsrc-card: use asoc_simple_card_parse_daifmt()
26) ASoC: rsrc-card: use asoc_simple_card_parse_dailink_name()
27) ASoC: rsrc-card: use asoc_simple_dai instead of rsrc_card_dai
28) ASoC: rsrc-card: use asoc_simple_card_parse_clk()
29) ASoC: rsrc-card: use asoc_simple_card_parse_endpoint()
30) ASoC: rsrc-card: use asoc_simple_card_parse_card_name()
31) ASoC: rsrc-card: use asoc_simple_card_parse_card_prefix()
32) ASoC: rsrc-card: use asoc_simple_card_parse_tdm()
33) ASoC: rsrc-card: use asoc_simple_card_init_dai()
34) ASoC: rsrc-card: use asoc_simple_card_canonicalize_cpu()
35) ASoC: rsrc-card: use asoc_simple_card_canonicalize_dailink()
36) ASoC: rsrc-card: use asoc_simple_card_clean_reference()
37) ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase1
38) ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase2
39) ASoC: rsrc-card: rename rsrc-card to simple-dpcm-card phase3
Documentation/devicetree/bindings/sound/renesas,rsrc-card.txt | 75 --------------
Documentation/devicetree/bindings/sound/simple-dpcm-card.txt | 79 +++++++++++++++
include/sound/simple_card.h | 11 +--
include/sound/simple_card_utils.h | 77 +++++++++++++++
sound/soc/generic/Kconfig | 10 ++
sound/soc/generic/Makefile | 4 +
sound/soc/generic/simple-card-utils.c | 288 +++++++++++++++++++++++++++++++++++++++++++++++++++++
sound/soc/generic/simple-card.c | 424 ++++++++++++++++++++++++------------------------------------------------------
sound/soc/generic/simple-dpcm-card.c | 351 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
sound/soc/sh/Kconfig | 5 -
sound/soc/sh/rcar/Makefile | 3 -
sound/soc/sh/rcar/rsrc-card.c | 529 --------------------------------------------------------------------------------------------------
12 files changed, 937 insertions(+), 919 deletions(-)
More information about the Alsa-devel
mailing list