[alsa-devel] [PATCH v4 2/4] ALSA: compress: Add function to indicate the stream has gone bad
Vinod Koul
vinod.koul at intel.com
Tue Apr 19 08:25:52 CEST 2016
On Tue, Apr 12, 2016 at 11:32:07AM +0100, Charles Keepax wrote:
> + * @state: state to transition the stream to
> + *
> + * Stop the stream and set its state.
> + *
> + * Should be called with compressed device lock held.
> + */
> +int snd_compr_stop_error(struct snd_compr_stream *stream,
> + snd_pcm_state_t state)
Do we want the state as an agument here, since we are invoking stop, it
should transistion to the stopped state
> +{
> + if (stream->runtime->state == state)
> + return 0;
> +
> + stream->runtime->state = state;
> +
> + queue_delayed_work(system_power_efficient_wq, &stream->error_work, 0);
> +
> + return 0;
> +}
> +EXPORT_SYMBOL_GPL(snd_compr_stop_error);
--
~Vinod
More information about the Alsa-devel
mailing list