[alsa-devel] [PATCH] ASoC: soc-core: call soc_cleanup_card_debugfs() from snd_soc_unregister_card()

Kuninori Morimoto kuninori.morimoto.gx at renesas.com
Tue Mar 24 02:44:49 CET 2015


From: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>

Card debugfs is created in snd_soc_register_card(), but
soc_cleanup_card_debugfs() is called from soc_cleanup_card_resources().
Cleanup function should be called from paired unregister function.

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx at renesas.com>
---
 sound/soc/soc-core.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 4c26074..211783f 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -1751,8 +1751,6 @@ static int soc_cleanup_card_resources(struct snd_soc_card *card)
 	/* remove and free each DAI */
 	soc_remove_dai_links(card);
 
-	soc_cleanup_card_debugfs(card);
-
 	/* remove the card */
 	if (card->remove)
 		card->remove(card);
@@ -2447,6 +2445,7 @@ int snd_soc_unregister_card(struct snd_soc_card *card)
 		card->instantiated = false;
 		snd_soc_dapm_shutdown(card);
 		soc_cleanup_card_resources(card);
+		soc_cleanup_card_debugfs(card);
 		dev_dbg(card->dev, "ASoC: Unregistered card '%s'\n", card->name);
 	}
 
-- 
1.9.1



More information about the Alsa-devel mailing list