[alsa-devel] [PATCH] sound: sh: Fix up namespace collision in sh_dac_audio.
Takashi Iwai
tiwai at suse.de
Mon May 21 11:38:10 CEST 2012
At Mon, 21 May 2012 18:21:54 +0900,
Paul Mundt wrote:
>
> The module_platform_driver() conversion ended up tripping over the driver
> name, leading to confusion in the macro with regards to 'driver' being
> redefined. rename it to something slightly more suitable to avoid
> namespace collisions.
>
> sound/sh/sh_dac_audio.c:444:122: error: conflicting types for 'driver_init'
> include/linux/device.h:773:6: note: previous declaration of 'driver_init' was here
> make[3]: *** [sound/sh/sh_dac_audio.o] Error 1
>
> Signed-off-by: Paul Mundt <lethal at linux-sh.org>
Thanks, applied now.
Takashi
>
> ---
>
> sound/sh/sh_dac_audio.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/sound/sh/sh_dac_audio.c b/sound/sh/sh_dac_audio.c
> index b11f82b..f8b01c7 100644
> --- a/sound/sh/sh_dac_audio.c
> +++ b/sound/sh/sh_dac_audio.c
> @@ -433,7 +433,7 @@ probe_error:
> /*
> * "driver" definition
> */
> -static struct platform_driver driver = {
> +static struct platform_driver sh_dac_driver = {
> .probe = snd_sh_dac_probe,
> .remove = snd_sh_dac_remove,
> .driver = {
> @@ -441,4 +441,4 @@ static struct platform_driver driver = {
> },
> };
>
> -module_platform_driver(driver);
> +module_platform_driver(sh_dac_driver);
>
More information about the Alsa-devel
mailing list