[alsa-devel] [PATCH] sound/soc: rename vol to volatile_register as appropriate
Joe Perches
joe at perches.com
Wed Oct 13 14:55:48 CEST 2010
On Wed, 2010-10-13 at 13:33 +0100, Mark Brown wrote:
> On Wed, Oct 13, 2010 at 05:10:45AM -0700, Joe Perches wrote:
> > Rename the declaration and uses of variables
> > named vol to volatile_register to avoid name
> > clash with the much more common use of vol
> > for volume.
> Are any of the contexts actually ambiguous? I have to say I don't find
> this useful. If the register I/O code knows anything about volumes I'd
> say we've probably messed up somewhere.
Looking at the 2 register access routines where
volatile_register/vol is used, I'd say those
routines aren't useful at all and the checks
should be inline instead.
This sort of wrapper routine doesn't serve
much of a purpose to me:
static int wm8904_volatile_register(unsigned int reg)
{
- return wm8904_access[reg].vol;
+ return wm8904_access[reg].volatile_register;
}
> It's used as the field name for volatility in all the
> drivers I can remember that use a table to look volatility up in
> register properties.
I did a grep for vol in sound, I found the uses
where it was for volatile and patched them.
Are there others? Perhaps, but I don't think so.
Probably not in sound. Was there some other
subsystem you meant? Maybe you have examples
I missed?
More information about the Alsa-devel
mailing list