[alsa-devel] [PATCH 1/3] ascenario: Rename SND_SCN_INT_QOS to SND_SCN_INT_QOS_POWER
Stefan Schmidt
stefan at datenfreihafen.org
Wed Oct 7 15:55:56 CEST 2009
From: Stefan Schmidt <stefan at slimlogic.co.uk>
This brings it in line with SND_POWER_QOS_* and emphasis the power consumption
background.
Signed-off-by: Stefan Schmidt <stefan at slimlogic.co.uk>
---
include/ascenario.h | 2 +-
src/ascenario.c | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/ascenario.h b/include/ascenario.h
index b139551..3055cfa 100644
--- a/include/ascenario.h
+++ b/include/ascenario.h
@@ -125,7 +125,7 @@ extern "C" {
* Integer types
*/
/** QoS volume */
-#define SND_SCN_INT_QOS 1
+#define SND_SCN_INT_QOS_POWER 1
/** Scenario container */
typedef struct snd_scenario snd_scenario_t;
diff --git a/src/ascenario.c b/src/ascenario.c
index 19d3856..f90192c 100644
--- a/src/ascenario.c
+++ b/src/ascenario.c
@@ -1323,7 +1323,7 @@ const char *snd_scenario_get_scn(snd_scenario_t *scn)
int snd_scenario_set_integer(snd_scenario_t *scn, int type, int value)
{
switch (type) {
- case SND_SCN_INT_QOS:
+ case SND_SCN_INT_QOS_POWER:
scn->scenario[scn->current_scenario].qos = value;
return 0;
default:
@@ -1336,7 +1336,7 @@ int snd_scenario_get_integer(snd_scenario_t *scn, int type, int *value)
if (value == NULL)
return -EINVAL;
switch (type) {
- case SND_SCN_INT_QOS:
+ case SND_SCN_INT_QOS_POWER:
*value = scn->scenario[scn->current_scenario].qos;
return 0;
default:
--
1.6.4.3
More information about the Alsa-devel
mailing list