[alsa-devel] sbxfi - What works/doesn't summary

Jason Harvey softdevice at jasonline.co.uk
Wed Oct 29 18:01:29 CET 2008

Takashi Iwai wrote:
> The last change was:
>    commit 941ec54e47f635f63621d3852253d9ef9b11132f
>    Author: Takashi Iwai <tiwai at suse.de>
>    Date:   Tue Oct 28 08:00:24 2008 +0100
>       sbxfi - Use 48kHz as default
> Though, I'm glad to hear that it's working, of course :)
> Or, did you apply my last patch I posted?
> Hmm... I haven't changed sbxfi code since yesterday.
Ah... a little version confusion here...

This morning I downloaded unstable again and tried the patch.
It wasn't working, garbled sound through pulseaudio as previously mentioned.
I worked out my pulse installation was missing a few packages (Fedora 
folk why aren't all pulse related packages named pulse-* ?)
Not sure what changed but once all the pulse pieces were in place and I 
had locked the default device to the sbxfi it all sounded great.
That was without the patch.

Just applied the patch again and everything still works.

>> Can't get mplayer to play at the same time as flash in firefox but I 
>> don't really know if I've ever managed to do that under pulse...
> The flash with PA can work with libflashsupport.
> It'd be better to use it with flash-10, though.
Thank you, I had grabbed flash 10 a couple of days ago as I tried to get 
it all going.
Although it was making nice sounds it turns out it was not using pulse.
Now I have the volume control installed I can see what is going on...
Cured flash by installing libflashsupport.i386
libflashsupport.x86_64 package doesn't really help with adobe's i386 
flash. Doh.


More information about the Alsa-devel mailing list