[alsa-devel] Possible regression on Sigmatel 9205

Manuel Naranjo manuel at aircable.net
Wed Oct 15 16:14:49 CEST 2008

On Wed, Oct 15, 2008 at 10:50 AM, Matthew Ranostay
<mranostay at embeddedalley.com> wrote:
> Manuel Naranjo wrote:
>>>> Hello everyone,
>>>> Sorry to interrupt you all, but I had been trying to get the digital mic
>>>> of my Dell Inspiron 1521 for the last 5 days without any sucess.
>>>> I'm running kernel 2.6.27 with included ALSA, I also tried GIT alsa, and
>>>> the result is the same, the mic works, but the volume is so damn low
>>>> that there's no way to hear it.
>>>> I checked dell's windows drivers and my board belongs to the M4_8 line
>>>> and not to the M4_2 as suggested in alsa source. I also did a diff
>>>> between M4_2 and M4_8 and there are some differences, specially in GPIO.
>>>> I don't know what else to do now, I had tried everything. Last working
>>>> alsa was 1.15 if I'm not wrong, but I'm not able to backport 1.15 to the
>>>> new kernel, for some reason it fails to compile.
>>> Do you have "Digital" volume adjusted properly (in the control name
>>> "Digital Capture Volume")?
>>> Usually this should be in exactly middle, which corresponds to 0dB.
>> Yep I did. I guess you're tired of stupid support requests. Don't
>> worry I think I know what I'm doing very well. Tried with lots of
>> different model options for the module too, none worked.
>>> Anyway, please show the alsa-info.sh output with --no-upload option.
>>> This will tell us more detailed information.
>> Sure, I'm attaching 2 version. One is by not passing any argument to
>> the module after a fresh boot, the other one is by using
>> model=dell-m42 which should be mine according to my PID. BTW there are
>> lots of bug tickets opened for this card over the net, most related to
>> Ubuntu and kernel > 2.6.24
>> Thanks,
>> Manuel
> I only see the 'Digital Capture Volume' in the no parameters output.
> You generally need to run 'arecord -f cd foo.wav' to load the digital softvol mixer.
> Thanks,
> Matt Ranostay

Sorry, ok I did that. With pulseaudio running calling to arecord
fails. But if I disable it, then close X and restart X, I start
getting some sound with arecord. Volume isn't as high as it was with
kernel 2.6.24 but it works better.

Here's my alsa-info
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: alsa-info.txt
Url: http://mailman.alsa-project.org/pipermail/alsa-devel/attachments/20081015/50909cab/attachment-0001.txt 

More information about the Alsa-devel mailing list