[alsa-devel] [PATCH 03/10] ASoC: Tweak tlv320aicx reg_cache_size
Mark Brown
broonie at opensource.wolfsonmicro.com
Wed Jun 11 14:47:08 CEST 2008
ASoC codec drivers frequently set the register cache size using sizeof()
rather than ARRAY_SIZE(). For tlv320aicx either is correct since the
registers are 8 bit but update to use ARRAY_SIZE() for clarity.
Signed-off-by: Mark Brown <broonie at opensource.wolfsonmicro.com>
Cc: Jarkko Nikula <jarkko.nikula at nokia.com>
---
sound/soc/codecs/tlv320aic3x.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/sound/soc/codecs/tlv320aic3x.c b/sound/soc/codecs/tlv320aic3x.c
index dc8a38d..528c26a 100644
--- a/sound/soc/codecs/tlv320aic3x.c
+++ b/sound/soc/codecs/tlv320aic3x.c
@@ -1021,7 +1021,7 @@ static int aic3x_init(struct snd_soc_device *socdev)
codec->set_bias_level = aic3x_set_bias_level;
codec->dai = &aic3x_dai;
codec->num_dai = 1;
- codec->reg_cache_size = sizeof(aic3x_reg);
+ codec->reg_cache_size = ARRAY_SIZE(aic3x_reg);
codec->reg_cache = kmemdup(aic3x_reg, sizeof(aic3x_reg), GFP_KERNEL);
if (codec->reg_cache == NULL)
return -ENOMEM;
--
1.5.5.3
More information about the Alsa-devel
mailing list