[alsa-devel] [patch] ASoC: wm8994: missing break in wm8994_aif3_hw_params()
The missing break here means that we always return early and the function is a no-op.
Signed-off-by: Dan Carpenter dan.carpenter@oracle.com ---
diff --git a/sound/soc/codecs/wm8994.c b/sound/soc/codecs/wm8994.c index 14094f5..1eb152c 100644 --- a/sound/soc/codecs/wm8994.c +++ b/sound/soc/codecs/wm8994.c @@ -2882,6 +2882,7 @@ static int wm8994_aif3_hw_params(struct snd_pcm_substream *substream, default: return 0; } + break; default: return 0; }
Am 30.04.2013 09:24, schrieb Dan Carpenter:
The missing break here means that we always return early and the function is a no-op.
Signed-off-by: Dan Carpenter dan.carpenter@oracle.com
diff --git a/sound/soc/codecs/wm8994.c b/sound/soc/codecs/wm8994.c index 14094f5..1eb152c 100644 --- a/sound/soc/codecs/wm8994.c +++ b/sound/soc/codecs/wm8994.c @@ -2882,6 +2882,7 @@ static int wm8994_aif3_hw_params(struct snd_pcm_substream *substream, default: return 0; }
default: return 0; }break;
the patch seems ok, but i would question the wisdom of a nested switch here, obviously the readability suffers and since it is only one case it seems better to be replaced it with
if (dai->id != 3) return 0;
Please can the maintainer comment on that ?
just my 2 cents, wh
On Tue, Apr 30, 2013 at 09:49:34AM +0200, walter harms wrote:
the patch seems ok, but i would question the wisdom of a nested switch here, obviously the readability suffers and since it is only one case it seems better to be replaced it with
I don't think that's a good idea, it does nothing for the readability and isn't idiomatic.
participants (3)
-
Dan Carpenter
-
Mark Brown
-
walter harms