[PATCH 00/10] Documentation build warning fixes
Hi Jon,
This small series contain a series of fixes for the documentation. it is against your docs-next branch.
Three of the patches fix duplicated symbols at the ABI documents. There are still some ABI warnings from IIO, but all but one were already fixed at linux-next. So, hopefully, after having everything merged, the ABI warnings will be solved.
Mauro Carvalho Chehab (10): docs: update sysfs-platform_profile.rst reference docs: vcpu-requests.rst: fix reference for atomic ops docs: translations/zh_CN: fix a typo at 8.Conclusion.rst docs: sched-bwc.rst: fix a typo on a doc name docs: update pin-control.rst references docs: virt: api.rst: fix a pointer to SGX documentation docs: ABI: iommu: remove duplicated definition for sysfs-kernel-iommu_groups docs: ABI: sysfs-class-backlight: unify ambient light zone nodes docs: ABI: sysfs-class-led-trigger-pattern: remove repeat duplication iio: documentation: fix a typo
Documentation/ABI/testing/sysfs-bus-iio | 4 +- .../ABI/testing/sysfs-class-backlight | 100 ++++++++++++++++++ .../ABI/testing/sysfs-class-backlight-adp5520 | 31 ------ .../ABI/testing/sysfs-class-backlight-adp8860 | 37 ------- .../sysfs-class-backlight-driver-adp8870 | 32 ------ .../testing/sysfs-class-led-driver-el15203000 | 9 -- .../testing/sysfs-class-led-trigger-pattern | 3 + .../ABI/testing/sysfs-kernel-iommu_groups | 12 +-- Documentation/scheduler/sched-bwc.rst | 2 +- .../zh_CN/process/8.Conclusion.rst | 2 +- Documentation/virt/kvm/api.rst | 2 +- Documentation/virt/kvm/vcpu-requests.rst | 2 +- include/linux/device.h | 2 +- include/linux/mfd/madera/pdata.h | 2 +- include/linux/pinctrl/pinconf-generic.h | 2 +- include/linux/platform_profile.h | 2 +- 16 files changed, 117 insertions(+), 127 deletions(-) delete mode 100644 Documentation/ABI/testing/sysfs-class-backlight-adp5520 delete mode 100644 Documentation/ABI/testing/sysfs-class-backlight-adp8860 delete mode 100644 Documentation/ABI/testing/sysfs-class-backlight-driver-adp8870 delete mode 100644 Documentation/ABI/testing/sysfs-class-led-driver-el15203000
Changeset 5513b411ea5b ("Documentation: rename pinctl to pin-control") renamed: Documentation/driver-api/pinctl.rst to: Documentation/driver-api/pin-control.rst.
Update the cross-references accordingly.
Fixes: 5513b411ea5b ("Documentation: rename pinctl to pin-control") Signed-off-by: Mauro Carvalho Chehab mchehab+huawei@kernel.org --- include/linux/device.h | 2 +- include/linux/mfd/madera/pdata.h | 2 +- include/linux/pinctrl/pinconf-generic.h | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/linux/device.h b/include/linux/device.h index 38a2071cf776..d1183cfdc8fb 100644 --- a/include/linux/device.h +++ b/include/linux/device.h @@ -399,7 +399,7 @@ struct dev_links_info { * along with subsystem-level and driver-level callbacks. * @em_pd: device's energy model performance domain * @pins: For device pin management. - * See Documentation/driver-api/pinctl.rst for details. + * See Documentation/driver-api/pin-control.rst for details. * @msi_list: Hosts MSI descriptors * @msi_domain: The generic MSI domain this device is using. * @numa_node: NUMA node this device is close to. diff --git a/include/linux/mfd/madera/pdata.h b/include/linux/mfd/madera/pdata.h index 601cbbc10370..32e3470708ed 100644 --- a/include/linux/mfd/madera/pdata.h +++ b/include/linux/mfd/madera/pdata.h @@ -31,7 +31,7 @@ struct pinctrl_map; * @irq_flags: Mode for primary IRQ (defaults to active low) * @gpio_base: Base GPIO number * @gpio_configs: Array of GPIO configurations (See - * Documentation/driver-api/pinctl.rst) + * Documentation/driver-api/pin-control.rst) * @n_gpio_configs: Number of entries in gpio_configs * @gpsw: General purpose switch mode setting. Depends on the external * hardware connected to the switch. (See the SW1_MODE field diff --git a/include/linux/pinctrl/pinconf-generic.h b/include/linux/pinctrl/pinconf-generic.h index e18ab3d5908f..5a96602a3316 100644 --- a/include/linux/pinctrl/pinconf-generic.h +++ b/include/linux/pinctrl/pinconf-generic.h @@ -89,7 +89,7 @@ struct pinctrl_map; * it. * @PIN_CONFIG_OUTPUT: this will configure the pin as an output and drive a * value on the line. Use argument 1 to indicate high level, argument 0 to - * indicate low level. (Please see Documentation/driver-api/pinctl.rst, + * indicate low level. (Please see Documentation/driver-api/pin-control.rst, * section "GPIO mode pitfalls" for a discussion around this parameter.) * @PIN_CONFIG_PERSIST_STATE: retain pin state across sleep or controller reset * @PIN_CONFIG_POWER_SOURCE: if the pin can select between different power
On Wed, May 19, 2021 at 10:51:42AM +0200, Mauro Carvalho Chehab wrote:
Changeset 5513b411ea5b ("Documentation: rename pinctl to pin-control") renamed: Documentation/driver-api/pinctl.rst to: Documentation/driver-api/pin-control.rst.
Update the cross-references accordingly.
Fixes: 5513b411ea5b ("Documentation: rename pinctl to pin-control") Signed-off-by: Mauro Carvalho Chehab mchehab+huawei@kernel.org
For the Madera change:
Acked-by: Charles Keepax ckeepax@opensource.cirrus.com
Thanks, Charles
On Wed, 19 May 2021, Mauro Carvalho Chehab wrote:
Changeset 5513b411ea5b ("Documentation: rename pinctl to pin-control") renamed: Documentation/driver-api/pinctl.rst to: Documentation/driver-api/pin-control.rst.
Update the cross-references accordingly.
Fixes: 5513b411ea5b ("Documentation: rename pinctl to pin-control") Signed-off-by: Mauro Carvalho Chehab mchehab+huawei@kernel.org
include/linux/device.h | 2 +-
include/linux/mfd/madera/pdata.h | 2 +-
Acked-by: Lee Jones lee.jones@linaro.org
include/linux/pinctrl/pinconf-generic.h | 2 +- 3 files changed, 3 insertions(+), 3 deletions(-)
On Wed, May 19, 2021 at 10:51 AM Mauro Carvalho Chehab mchehab+huawei@kernel.org wrote:
Changeset 5513b411ea5b ("Documentation: rename pinctl to pin-control") renamed: Documentation/driver-api/pinctl.rst to: Documentation/driver-api/pin-control.rst.
Update the cross-references accordingly.
Fixes: 5513b411ea5b ("Documentation: rename pinctl to pin-control") Signed-off-by: Mauro Carvalho Chehab mchehab+huawei@kernel.org
Acked-by: Linus Walleij linus.walleij@linaro.org I suppose you take it through the doc tree? I can apply it if you prefer.
Yours, Linus Walleij
Mauro Carvalho Chehab mchehab+huawei@kernel.org writes:
Hi Jon,
This small series contain a series of fixes for the documentation. it is against your docs-next branch.
Three of the patches fix duplicated symbols at the ABI documents. There are still some ABI warnings from IIO, but all but one were already fixed at linux-next. So, hopefully, after having everything merged, the ABI warnings will be solved.
Mauro Carvalho Chehab (10): docs: update sysfs-platform_profile.rst reference docs: vcpu-requests.rst: fix reference for atomic ops docs: translations/zh_CN: fix a typo at 8.Conclusion.rst docs: sched-bwc.rst: fix a typo on a doc name docs: update pin-control.rst references docs: virt: api.rst: fix a pointer to SGX documentation docs: ABI: iommu: remove duplicated definition for sysfs-kernel-iommu_groups docs: ABI: sysfs-class-backlight: unify ambient light zone nodes docs: ABI: sysfs-class-led-trigger-pattern: remove repeat duplication iio: documentation: fix a typo
Seems like good stuff. The last patch in the series, though, adds a warning:
Documentation/ABI/testing/sysfs-bus-iio:799: WARNING: Inline emphasis start-string without end-string.
So I left that one out and applied the rest.
Thanks,
jon
participants (5)
-
Charles Keepax
-
Jonathan Corbet
-
Lee Jones
-
Linus Walleij
-
Mauro Carvalho Chehab