[PATCH] ASoC: ti: omap-hdmi: Fix too long driver name
Set driver name to DRV_NAME. This simplifies the code and gets rid of the following error messages:
ASoC: driver name too long 'HDMI 58040000.encoder' -> 'HDMI_58040000_e'
Signed-off-by: Primoz Fiser primoz.fiser@norik.com --- sound/soc/ti/omap-hdmi.c | 6 +----- 1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/sound/soc/ti/omap-hdmi.c b/sound/soc/ti/omap-hdmi.c index 639bc83f4263..3f35eedeea41 100644 --- a/sound/soc/ti/omap-hdmi.c +++ b/sound/soc/ti/omap-hdmi.c @@ -354,11 +354,7 @@ static int omap_hdmi_audio_probe(struct platform_device *pdev) if (!card) return -ENOMEM;
- card->name = devm_kasprintf(dev, GFP_KERNEL, - "HDMI %s", dev_name(ad->dssdev)); - if (!card->name) - return -ENOMEM; - + card->name = DRV_NAME; card->owner = THIS_MODULE; card->dai_link = devm_kzalloc(dev, sizeof(*(card->dai_link)), GFP_KERNEL);
On 6/6/24 10:06 AM, Primoz Fiser wrote:
Set driver name to DRV_NAME. This simplifies the code and gets rid of the following error messages:
ASoC: driver name too long 'HDMI 58040000.encoder' -> 'HDMI_58040000_e'
Signed-off-by: Primoz Fiser primoz.fiser@norik.com
sound/soc/ti/omap-hdmi.c | 6 +----- 1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/sound/soc/ti/omap-hdmi.c b/sound/soc/ti/omap-hdmi.c index 639bc83f4263..3f35eedeea41 100644 --- a/sound/soc/ti/omap-hdmi.c +++ b/sound/soc/ti/omap-hdmi.c @@ -354,11 +354,7 @@ static int omap_hdmi_audio_probe(struct platform_device *pdev) if (!card) return -ENOMEM;
- card->name = devm_kasprintf(dev, GFP_KERNEL,
"HDMI %s", dev_name(ad->dssdev));
- if (!card->name)
return -ENOMEM;
- card->name = DRV_NAME;
I think it would be better to name is simply "HDMI" instead
card->owner = THIS_MODULE; card->dai_link = devm_kzalloc(dev, sizeof(*(card->dai_link)), GFP_KERNEL);
On Thu, Jun 06, 2024 at 09:00:47PM +0300, Péter Ujfalusi wrote:
On 6/6/24 10:06 AM, Primoz Fiser wrote:
- card->name = devm_kasprintf(dev, GFP_KERNEL,
"HDMI %s", dev_name(ad->dssdev));
- if (!card->name)
return -ENOMEM;
- card->name = DRV_NAME;
I think it would be better to name is simply "HDMI" instead
That does seem a bit more user friendly.
Hi,
On 6. 06. 24 20:01, Mark Brown wrote:
On Thu, Jun 06, 2024 at 09:00:47PM +0300, Péter Ujfalusi wrote:
On 6/6/24 10:06 AM, Primoz Fiser wrote:
- card->name = devm_kasprintf(dev, GFP_KERNEL,
"HDMI %s", dev_name(ad->dssdev));
- if (!card->name)
return -ENOMEM;
- card->name = DRV_NAME;
I think it would be better to name is simply "HDMI" instead
That does seem a bit more user friendly.
So card->name = "HDMI" for v2?
Thanks, BR, Primoz
participants (3)
-
Mark Brown
-
Primoz Fiser
-
Péter Ujfalusi