[alsa-devel] [PATCH] Revert "ASoC: core: use component driver name as component name"
Using component driver as a name is not unique and it breaks audio in certain configurations, e.g. Hardkernel Odroid XU3 board where following components are registered: - 3830000.i2s with driver snd_dmaengine_pcm - 3830000.i2s-sec with driver snd_dmaengine_pcm - 3830000.i2s with driver 3830000.i2s-sec
This reverts commit b19671d6caf1ac393681864d5d85dda9fa99a448.
Signed-off-by: Krzysztof Kozlowski krzk@kernel.org --- sound/soc/soc-core.c | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c index 2d3520fca613..7abb017a83f3 100644 --- a/sound/soc/soc-core.c +++ b/sound/soc/soc-core.c @@ -3113,10 +3113,7 @@ static int snd_soc_component_initialize(struct snd_soc_component *component, { struct snd_soc_dapm_context *dapm;
- if (driver->name) - component->name = kstrdup(driver->name, GFP_KERNEL); - else - component->name = fmt_single_name(dev, &component->id); + component->name = fmt_single_name(dev, &component->id); if (!component->name) { dev_err(dev, "ASoC: Failed to allocate name\n"); return -ENOMEM;
participants (1)
-
Krzysztof Kozlowski